Weather Impact Southern Utah County Wireless Customers

Incident Report for Fusion Networks

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 14:11 MDT

Update

We are continuing to monitor for any further issues.
Posted Aug 14, 2026 - 14:07 MDT

Monitoring

Monsoon rains are impacting Southern Utah County wireless customers. We anticipate that as the weather lightens the wireless stability will improve.
Posted Aug 14, 2026 - 14:00 MDT
This incident affected: Fusion Internet.