Outage affecting Salem and Elk Ridge
Incident Report for Fusion Networks
Resolved
The emergency fiber repair has been completed. Our network monitoring system shows that service has been restored to all users.

If you are still having issues, please unplug your router from power and plug it back in.

If this does not resolve the issue, please contact our support team at 801-821-4785
Posted Mar 17, 2023 - 21:36 MDT
Update
Emergency repairs on the fiber have been completed. Service should restored.

If you are still having issues please unplug the power on your router and plug it back in. If that doesn't work please call 801-821-4785 and follow the prompt to talk to an on call technician.
Posted Mar 17, 2023 - 18:50 MDT
Update
Crews are actively splicing the fiber to repair it.
Posted Mar 17, 2023 - 18:05 MDT
Update
Crews have identified the location of the fiber cut along Salem Canal Road.

Splicing crews are working on an emergency repair to restore service as soon as possible.

Repair crews will remain on site tonight until service is restored.
Posted Mar 17, 2023 - 16:44 MDT
Identified
We are aware of the internet outage affecting Elk Ridge and Salem. There is an issue with the transport fiber between Salem and Salt Lake City. Crews are investigating the cause, but we think it may be a fiber has been cut.

We are actively working to restore connectivity and will post regular updates.
Posted Mar 17, 2023 - 13:35 MDT
This incident affected: Fusion Internet.