Engineers have identified and resolved the issue with the primary transit line. All services have been restored, and we are continuing to monitor the network. If you are a customer in Elk Ridge and you are still experiencing issues, please try rebooting your router. If the issue persists, please contact us at 801-821-4785 or support@fusionnetworks.me
Posted Apr 01, 2026 - 15:03 MDT
Update
Crews are continuing to work on restoring the primary line. Traffic remains routed over the secondary link. Service should be operational, but performance may still feel degraded.
Posted Apr 01, 2026 - 14:04 MDT
Update
Network have diverted traffic out a secondary link. Service may continue to be degraded, but should be online. Technicians are continuing to identify transport issue between Elk Ridge and SLC.
Posted Apr 01, 2026 - 12:39 MDT
Identified
The transit fiber between Elk Ridge and SLC is down. Crews are en route to site to investigate and repair. Fiber customers in Elk Ridge are currently experiencing an outage.