Fiber line work was successfully completed ahead of schedule. All customers in Elk Ridge should have internet service restored. If you are still having issues, unplug your router from power for 10 seconds and plug it back in. If additional help is needed, please contact our support team at 801.821.4785 or at support@fusionnetworks.me
Posted Mar 06, 2026 - 02:45 MST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2026 - 23:45 MST
Scheduled
Fusion Networks will be performing overnight emergency work on fiber lines in Elk Ridge. Customers in Elk Ridge will experience a downtime as we migrate fiber paths.
Posted Mar 05, 2026 - 13:33 MST
This scheduled maintenance affected: Fusion Internet.