Torrential Rain affecting service
Incident Report for Fusion Networks
Resolved
This incident has been resolved.
Posted Mar 10, 2023 - 23:52 MST
Identified
We are monitoring the equipment and doing what we can to mitigate down time.
Posted Mar 10, 2023 - 21:00 MST
This incident affected: Fusion Internet.