All Systems Operational
Fusion Internet Operational
90 days ago
100.0 % uptime
Today
Test Component ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Apr 24, 2024

No incidents reported today.

Apr 23, 2024

No incidents reported.

Apr 22, 2024

No incidents reported.

Apr 21, 2024

No incidents reported.

Apr 20, 2024

No incidents reported.

Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.

Apr 17, 2024
Completed - The scheduled maintenance has been completed. If you do not have service, please contact our support team at support@fusionnetworks.me or at 801.821.4785
Apr 17, 04:12 MDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 17, 00:00 MDT
Scheduled - Technicians will be performing maintenance and upgrades to fiber optic lines in Elk Ridge. Customers in Elk Ridge who are on a fiber optic connection may experience interruption in service. We anticipate this work will begin at midnight and service restored by 5am.
Apr 16, 20:15 MDT
Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

No incidents reported.

Apr 10, 2024

No incidents reported.